【题目描述】
输入一棵二叉树的先序和中序遍历序列,输出其后序遍历序列。
【输入】
共两行,第一行一个字符串,表示树的先序遍历,第二行一个字符串,表示树的中序遍历。树的结点一律用小写字母表示。
【输出】
一行,表示树的后序遍历序列。
【输入样例】
abdec
dbeac【输出样例】
debca
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 101
#define MOD 123
#define E 1e-6
using namespace std;
string str1,str2;
void calculate(int left1,int right1,int left2,int right2)
{
int m=str2.find(str1[left1]);
if(m>left2)
calculate(left1+1,left1+m-left2,left2,m-1);
if(m<right2)
calculate(left1+m-left2+1,right1,m+1,right2);
cout<<str1[left1];
}
int main()
{
cin>>str1>>str2;
calculate(0,str1.length()-1,0,str2.length()-1);
cout<<endl;
return 0;
}
信息学奥赛一本通T1339:树与二叉树 求后序遍历 归属于 树与二叉树,更多同类题解源程序见:树与二叉树 和 求后序遍历
0 篇文章
如果觉得我的文章对您有用,请随意打赏。你的支持将鼓励我继续创作!