信息学奥赛一本通T1273:背包问题 货币系统

【题目描述】给你一个n种面值的货币系统,求组成面值为m的货币有多少种方案。【输入】第一行为n和m。【输出】一行,方案数。【输入样例】3 10        //3种面值组成面值为10的方案【输出样例】10          //有10种方案【源程序】 

信息学奥赛一本通T1273:货币系统

【题目描述】

给你一个n种面值的货币系统,求组成面值为m的货币有多少种方案。

【输入】

第一行为n和m。

【输出】

一行,方案数。

【输入样例】

3 10        //3种面值组成面值为10的方案
1           //面值1
2           //面值2
5           //面值5

【输出样例】

10          //有10种方案

【源程序】

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 10001
#define MOD 2520
#define E 1e-12
using namespace std;
long long a[N],f[N];
int main()
{
    int n,m;
    cin>>n>>m;
    f[0]=1;
    for(int i=1;i<=n;i++)
        cin>>a[i];
    for(int i=1;i<=n;i++)
        for(int j=a[i];j<=m;j++)
            f[j]+=f[j-a[i]];
    cout<<f[m]<<endl;
    return 0;
}

 

信息学奥赛一本通T1273:背包问题 货币系统 归属于 背包问题,更多同类题解源程序见:背包问题 和 货币系统

0 条评论

请先 登录 后评论
不写代码的码农
轩爸

0 篇文章

作家榜 »

  1. admin 2 文章
  2. 张芳 0 文章
  3. hanna 0 文章
  4. Jason 0 文章
  5. lixiaioqian 0 文章
  6. GeraldWrora 0 文章
  7. 董伟 0 文章
  8. 信奥达人 0 文章