【题目描述】
输入一个字符串,输出该字符串是否回文。回文是指顺读和倒读都一样的字符串。
【输入】
输入为一行字符串(字符串中没有空白字符,字符串长度不超过100)。
【输出】
如果字符串是回文,输出yes;否则,输出no。
【输入样例】
abcdedcba
【输出样例】
yes
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
char s[100];
int len,position;
int i,j;
gets(s);//获取字符串s
len=strlen(s);//求字符串长度
i=0;
j=len-1;//记录字符串首、尾位置
while( (i<j) &&(s[i]==s[j]) )//从首尾同时向中间判定,若不是回文串,则退出循环
{
i++;
j--;
}
if(i>=j)
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
return 0;
}
信息学奥赛一本通T1146:字符类型和字符数组 判断字符串是否为回文 归属于 字符类型和字符数组,更多同类题解源程序见:字符类型和字符数组 和 判断字符串是否为回文
0 篇文章
如果觉得我的文章对您有用,请随意打赏。你的支持将鼓励我继续创作!