【题目描述】
现代的人对于本家族血统越来越感兴趣,现在给出充足的父子关系,请你编写程序找到某个人的最早的祖先。
【输入】
由多行组成,首先是一系列有关父子关系的描述,其中每一组父子关系由二行组成,用#name的形式描写一组父子关系中的父亲的名字,用+name的形式描写一组父子关系中的儿子的名字;接下来用?name的形式表示要求该人的最早的祖先;最后用单独的一个$表示文件结束。规定每个人的名字都有且只有6个字符,而且首字母大写,且没有任意两个人的名字相同。最多可能有1000组父子关系,总人数最多可能达到50000人,家谱中的记载不超过30代。
【输出】
按照输入的要求顺序,求出每一个要找祖先的人的祖先,格式:本人的名字+一个空格+祖先的名字+回车。
【输入样例】
#George
+Rodney
#Arthur
+Gareth
+Walter
#Gareth
+Edward
?Edward
?Walter
?Rodney
?Arthur
$【输出样例】
Edward Arthur
Walter Arthur
Rodney George
Arthur Arthur
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 10001
#define MOD 123
#define E 1e-6
using namespace std;
map <string,string> father;
string Find(string x)
{
if(father[x]==x)
return x;
return father[x]=Find(father[x]);
}
int main()
{
string str;
string temp1,temp2,temp3;
while(cin>>str&&str!="$")
{
if(str[0]=='#')
{
temp1=str.substr(1,str.size()-1);
if(father[temp1]=="")
father[temp1]=temp1;
}
else if(str[0]=='+')
{
temp2=str.substr(1,str.size()-1);
Find(temp1);
father[temp2]=father[temp1];
}
else if(str[0]=='?')
{
temp3=str.substr(1,str.size()-1);
Find(temp3);
cout<<temp3<<" "<<father[temp3]<<endl;
}
}
return 0;
}
信息学奥赛一本通T1388:并查集 家谱 归属于 并查集,更多同类题解源程序见:并查集 和 家谱
0 篇文章
如果觉得我的文章对您有用,请随意打赏。你的支持将鼓励我继续创作!